Anushri - just built but no midi input
  • Hi all,,

    I have just completed the Anushri build and all is working fine. But I can’t get a note playing from the MIDI input. I’ve checked the midi signal with my Struthi and its receiving. Its in synth mode and I’ve tried to detect the incoming MIDI as described in the manual.. I’ve checked the MIDI connectors and they appear to be soldered correctly..

    Any hints on how to debug this ?

    Best wishes

  • i guess you put it in the correct midi socket? (not trying to be super smart ass but that can happen. i also managed to swap pins when i soldered the midi sockets off board, just as an example)

  • What is the voltage on pin 6 of the 6N137, at rest, and when you send a lot of MIDI messages?

  • Thanks for the advice guys .. I’m not having a good start to the day. To furnish this thread with some more information.. Last night upon completion I had the drum machine working, and I could activate the drone on the synth by holding HOLD.. all knobs and buttons appeared to work fine. Everything apart from MIDI input issue.

    This morning, I checked all the solder points, however I may have put the 6N137 IC in back to front. Now I find the unit isn’t really powering up successfully, its random, sometimes the LEDs come on, sometimes they don’t.. I certainly don’t have the level of functionality I achieved last night. When it powers up now, I dont even have the drum machine or drone from the synth.

    Its currently sat here, powered up, with all 6 LEDs on. but it doesnt respond to anything.

    So, my issue seems to have got worse

    Thanks

  • @ rest = 0.429 v approx
    with MIDI = 0.46 – 0.49v

    Now please bear in mind I am by no means proficient in checking with a multimeter.. but these are my results

  • Remove all the chips except the LT1054 and do the voltage test as described in the build instructions page.

  • ok thanks, will do it now

  • I removed all the chips, and after a few minutes of testing voltages as described in the instructions, and getting values nothing like those described , it appears the psu has damaged and now doesnt power up..This is a similar case to another thread on this forum. I hope with a new psu it’ll power up fine..

  • Make sure you put them(chips) in the right way, and be prepared that some may be damaged :/

    I would take the time to take a closer look at your board, there’s a good chance that there’s a not entirely good solder joint somewhere :(

  • I just found another psu in the office, its a 7v dc… i connected it.. and done a quick voltage check like the description and the values are pretty much spot on.. I’m putting the ICs back in now to test

  • chips in, powers up.. and drum machine working so far

  • drone working.. can tweak the filter, resonance and pretty much everything it seems .. I’ll check the 6N137 for midi data

  • it appears that the DCO is working and not VCOs.. ie it only make a synth sound when sub is set to DCO...

  • Ok guys, heres today update.

    I’ve got the board powering fine on 7v psu.. Its the only one i have in the house for now until next week. ... The VCO is not functioning. I can only get sounds when sub is set to DCO.. the filters, lfos, amp env all appears to work fine.. the drum machine also works fine.. all pots appear to do their job, except ofcourse anything related to the VCO, which doesn’t fire a shot… The MIDI input isn’t functioning also, I have checked with a number a MIDI sources, and nothing..

    the voltage for the 6th pin on 6N137
    resting = 2.17v / varies
    with MIDI = fluctates a little, but not precise

    could someone be so kind as to have a look at these results and give me some leads on how to solve this problem. I have little electronics experience, however I did successfully build the Struthi.. I have a decent multimeter here and a pretty good scope but I have little experience using the scope.. so if further tests are required that involve using the scope, please give me some advice on that…

    I’ve done the tests and here are my results

    1. 7.16v
    2. 6.36v
    3. -5.61v

    Red points are all coming in at approx 4.9v
    Green point -4.9v
    Purple Points ** not quite sure where to check here.., left or right pin ??
    Cyan Point -4.13v

    A. Seems fine, when i move pitch up and down using one of the knows, the votage goes up and down.. appears ok
    B. Again, seems fine, when VCF is modulating, the voltage goes up and down..
    C. Seems good.. at rest is ov.. when drone is on = 1v , when sequencer is trigger notes = 3.44v approx
    D. Hard to get a reading, appears to fluctuate alot.
    E. doesnt fluctate , stable at 4.88v
    F. 3v stable
    G. -3.33v
    H. -3.34v
    I. -4.89v
    J. -4.89v
    K. 0.918v
    L. Fluctuates, appears fine..
    M. N. O. Filters appear fine, will self oscillate if needed.
    P. Fuzz appears to work fine.
    U. 2.44v
    V. 3.71v

  • Regarding MIDI, resolder all pins of the optocoupler. Some more checks:

    • Pin 5 must be continuous with ground.
    • Pin 8 must be at +5V.

  • Thanks..

    I resoldered.. pin 5 = 0v pin 8 = 4.9v

  • Is pin 5 continuous with ground? It’s not because the meter shows 0V that it is continuous with ground.

  • How can i confirm this ?

  • With the meter in continuity testing mode.

  • Thanks for that.. Yes, pin 5 is continuous..

  • ok, good news.. I got the midi working… I think it was a resistor that wasnt soldered correctly.. thanks for the support… now, last issue.. the VCO...

    So, to test I have no sub osc or DCO playing..

    I am now getting a faint clicking on the VCO when i send MIDI notes to the unit..
    when i turn the VCO mix pot to the right I get clicking, set to the left there is no clipping.. the clipping seems to change when i move the PW mod pot..

    any hints where to check on the board to get the VCO working ?

  • Can you confirm that you have no signal at point F?

    Maybe you could post a picture of your board – we could spot incorrect parts or weak solder joints.

  • I’m checking the audio now.. see the fotos for any obvious mistakes.. (and please excuse my terrible soldering skills)

    anushri1.jpg
    3256 x 1879 - 856K
    anushri2.jpg
    3264 x 1887 - 856K
  • looks like that transistor in the upper LEFT corner is the wrong way around…

    lm4040 or IC1

  • well spotted shiftr.. you have eyes of a hawk.. thanks, I shall fix and test

  • 2N5485, and this will perfectly explain why the VCO doesn’t work.

  • Thanks alot guys, I’ve ordered a replacement part and I shall report back in a few days time with my progress.. I can’t wait to get it working.. the filter sounds so good, I can’t wait to hear the VCO...

  • Hi again.. I got a replacement 5485 in the board.. powered it up.. and sadly still the same issue as before.. no VCO..

    I checked the voltage on the purple point which i presume by looking at the photo is the center pin of the 5485 .. I get a reading of 4.8v .. not 4.1 as quoted in the tests..

    Any ideas where I should look next ? Thanks

  • uhhh the top left IC (that looks like a transistor) is a LM4040, if you replaced it with a 2n5485 no wonder it doesn’t work.

  • I am very sorry, MicMicMan and I were looking at a different part of the board… The 2N5485 is indeed correctly soldered; and the part that MicMicMan pointed to (IC1, LM4040 4.096V) is the one to replace.

    But I am puzzled, because if that’s the only mistake in your board, this wouldn’t explain why the VCO doesn’t work… (IC1 is responsible for shifting the CV outputs).

  • ahh.. ok .. so I just replaced the LM4040 with a 5485.. thats bad.. so, now I need to source a spare LM4040…

    my DCO has disappeared now..

  • Hi Again..I’ve made a little video to show whats working on the board.

    http://www.youtube.com/watch?v=tbzEWjCKZqw

    Ok, as you can see, and hear in the video, the VCO is slowly coming to life.. but.. only under certain circumstances..
    1. Mix is set to full right..
    2. PW is set to full right
    3. PW Mod is set to 1 o’clock..

    When not set to these values, the VCO fires blanks, click and the occasional pops..

    DCO is working fine now..

    Any ideas why this should be ?

  • I should also add that the VCO, when working is much lower volume than the DCO in comparison

  • I am a bit lost here…

    • Have you replaced the LM4040?
    • Is sync disabled (sync switch in lower position)
    • Voltage at pin A when you play a middle C and when you play a C one octave higher?
    • Do you get sound at point F?
  • For testing the unit, you should first set the PW parameter to noon and disable sync.

    Anyway, check the connections between both boards, maybe you can spend some time trying to ‘clean’ them with a toothbrush – there might be some short somewhere. Since it’s not responding to the played frequency and appears only on the square output, I suppose that the sound you’re hearing may be caused by some voltage bleedthrough. Not sure this phenomenon exists on a standard unit, that may be an indication…

  • Sorry about the delay answering this, been busy on other things.. I just powered it up again..

    1. I have replaced the LM4040.. I found LM4040DIZ 4.1 I think its correct.. and installed fine
    2. Sync is disabled yes
    3. Pin A shows 2.04 on middle C, and 2.55 one octave higher..
    4. I have checked with a multimeter and its a constant 3.09v, doesnt change with different keys or nothing.

    Still only the DCO firing, VCO fire the occasional splutter but nothing special.. I;ve tried cleaning the connections and no difference so far

  • What are the voltages on:

    • IC6 pin 6?
    • IC6 pin 11, when playing a middle C (C3), C4, C5?
    • Remove IC7. What is the current (in the mA range) flowing between pin 6 and pin 5 of the socket, for different notes?
    • Put IC7 back. Voltage on IC7 pin 7? IC8 pin 7?
  • 1. .271
    2. middle c =.781 c4 = .786 c5 .794
    3. 0
    4. ic7 pin 7 = 3.09 ic8 pin 7 = 5.02

  • I see 3 things broken here:

    • The voltages on IC6 pin 11 are incorrect. You should see a 0.2V/Octave slope there. This means something is wrong with IC6, IC7 or the resistors that surround it.
    • There should be some current flowing into pin 6.
    • The comparator output is high, so it should close Q1, discharge C9 and bring IC7 pin 7 low.

    I am a bit surprised by so many failures. This points to something wrong with either IC7 and IC6. Are these correctly soldered? No bent pin in the socket? You can try swapping in IC7 with another TL072. If you have a spare 2164 around you can try to do the swap – though “chip failure” is a very rare cause of problems.

  • Thanks for the diagnosis. I’ve ordered some replacement IC6 and IC7.

    The soldering seems fine around the sockets..the resistors appear to be correctly placed and soldered.

    Is it possible that these ICs suffered a blow when I may have overpowered it ?

    I am certain the VCO worked shortly after building the board, only when I first had the MIDI input problem did I being to resolder, changed the IC direction etc..

  • @changed the IC direction etc..@
    why would you do that?
    Reversing the chips is highly destructive….

  • I take back what I said about “chip failure” being a rare cause of problems. It is a very likely cause of problems if one of the chips was mounted backwards.

  • Hi, When the MIDI input failed to work shortly after finishing the build, I noticed the 6N137 may have been placed in the wrong direction (this is all mentioned in the posts above). During this time the PSU I was using stopped working.
    All the other ICs I remember to have been correctly positioned, certainly the TL072 and 2164 were correct.

    Very similar to the story mentioned in this post http://www.mutable-instruments.net/forum/discussion/2424/damaged-anushri-during-assembling#Item_12 PSU broke cos he had the IC’s in the wrong places…

  • I’ll report back when the replacement ICs arrived.. Thanks for the help guys, really appreciated..

  • Good news chaps.. the replacement TL072 arrived today.. and I didnt even need it.. It turns out my problem was the LM311 and TL072 were in fact in the wrong IC socket.. (I really must get a good desk lamp and magnifying glass!!!).. I swopped them around.. now the VCO is firing .. and firing very well … big thank to you all who helped me get through this and especially to Pinchenettes who absorbed my noobishness… together we got there.. and I hope this thread can help others in the future.. My biggest lessons on this project were the following:

    1. Dont try and do electronics on a friday night after a glass of wine and homegrown reefer..
    2. Get a good magnifying glass and work under a strong light, and match up the ICs with the schematic.. I foolishly tried to read the IC number from the PCB after the sockets were soldered on .. stupid of me I know… I wont do it again.

    Thanks again.. and I await the next projects.. x

  • I totally understand your pain, my issue was the 74HC165 and 74HC565 chips in the wrong spot.

  • @iximix, admviolin

    See here ;-)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion