Everything built, but something's wrong. SOLVED
  • I finished building today, and when I turn it on, nothing happens. I have checked all the voltages in the Troubleshooting section, and everything is fine.
    I have no lights and no sound. What else should I be checking?

    EDIT: The 595 and 165 ICs were swapped.

    board.jpg
    672 x 504 - 411K
  • I’m not sure if you’re as much a novice as I am, but my mistake was that my PSU had the incorrect polarity. Make sure you’re using center pin positive, and that the specs of the PSU match up.

  • I have a few compatible ones here. Thanks though!

  • Check the polarity of all the chips + post a high res picture of the back side of the board :)

  • While you are at it post pictures of both sides of the boards..

  • > I have checked all the voltages in the Troubleshooting section

    What have you checked exactly?

  • oh sorry i see you already put a picture… i was on mobile and the mobile site doesn’t always show pics. Can you post some pictures in a better resolution?

  • Check the values of C54 and C55. If they’re the wrong ones the ATMega won’t get a clock and won’t do anything. Check the connectors between the boards for badly soldered pins or shorts. Do you still have the correct voltage on all points mentioned in the troubleshooting section with the two boards connected?

  • Sorry, to clarify, I checked all the points mentioned in the power distribution and it all checks out. This was with both boards connected.

    bottomleft.jpg
    650 x 488 - 376K
    bottomright.jpg
    650 x 488 - 363K
    topleft.jpg
    667 x 500 - 419K
    topright.jpg
    667 x 500 - 379K
  • My soldering was ‘less than adequate’ on the 16 headers (the pins within pins connecting the two boards) Bad continuity. Also maybe clean the soldered part of the headers with alcohol (machine turned off) and light, careful toothbrushing (unless you use water soluble flux, leaded Kester – in which case use water and the tooth brush of a non family member).

    Also voltage check ‘each and every’ red, blue and green. You are going to be so happy when you solve this, the machine is most excellent.

  • i’d cut and rework all the long component leads (not only the additional heatsinks of the vregs) and see if it works then. i couldn’t spot any obvious mistake with that resolution (and with a quickscan™ ,) and chances are good that it’s solved as easy as finding a weak solder joint or unintended connection.

  • Dull colored solder – Are you using Lead free solder? If you are, be aware that it needs a good bit of heat before it truly works (more than traditional leaded solder, which is why leaded solder is recommended : It’s easier to work with)

  • It’s not lead free, it does look kind of dull, not sure if it was from my brushing it with a wire brush, or the lighting/angle. It’s much shinier at different angles.

  • Some of those leads look like they’re going to grow and produce flowers and fruit if exposed to sunlight. I always leave a ‘little bit’ of lead in case I have to desolder. You might have two leads/solder joints that are close to touching each other.

    You can reheat the solder and use ‘desoldering wick’ (a copper braided wire) to pull some solder off some of the suspect joints. Also, placing the bottom board in the case can put pressure on long leads and deflect them into a bad neighborhood. Maybe also check that the wire brush didn’t leave any little wire pieces lodged in a cranny.

  • Here’s some better and more recent pictures….I spent a few hours tonight going over all the joints to no avail…I’ve trimmed the trees as well. Perhaps some of your eagle eyes can see something I can’t?

    topfrontleft.jpg
    1291 x 968 - 979K
    topfrontright.jpg
    1250 x 937 - 1001K
    topbackright.jpg
    1250 x 938 - 914K
    topbackleft.jpg
    1291 x 968 - 1012K
    bottomfrontleft.jpg
    1200 x 900 - 982K
    bottomfrontright.jpg
    1220 x 915 - 997K
    bottombackright.jpg
    1240 x 930 - 1004K
    bottombackleft.jpg
    1200 x 900 - 982K
  • BTW, I should be looking for lights on startup correct?

  • yes, there are always indication lights on for the function you’re in.
    i’ve attached a pic. the red areas still have a lot of antennae and good amounts of excess solder. you can never tell whether a joint is good or not when they’re looking like that. maybe try to get them like the pins of your ICs look.
    i haven’t checked for resistor values yet, as there’s a good chance there’s bad connexions™

    antennas.jpg
    1200 x 900 - 70K
  • Yes, some LEDs always light up. To clarify, the braided copper ‘desoldering braid’ wicks up some of the heated, molten solder. Snip the used section of braid off (after wicking) and you’re ready to wick up the next connection. Maybe just wick some of the more obvious excess joints and see if that helps.

    Maybe check also to see that the ICs are seated in their socket and the numbers match correctly. Don’t lose heart, my Anushri needed some ‘loving attention’ before she sang for me.

  • Thanks guys, I’ve been using a solder sucker instead of a braid. As for the ICs, I took them all out as well and reseated them. Tomorrow I will attack it. Thanks for the suggestions.

  • yes i use a solder sucker for these too. can happen that there’s too little solder then, just don’t apply as much as before. make sure you touch the lead and the pad with the iron and heat them together. then add some solder so it looks good and cut off the remaining wires always as short as possible, keeps the possibilities for malfunction down.

  • okay! So, I’ve re-worked the bottom board, and I still have no lights or sound. I’ve checked the voltages on the chips (everything checks out), and the top board is getting power (when I check the switches/pots I get +5V)

    I’m running out of things to check or at least ideas.

    Thanks for the help so far, the board looks much cleaner.

    left.jpg
    1200 x 900 - 891K
    right.jpg
    1250 x 938 - 960K
  • Is it a kit or self-sourced?

  • A kit except for the one 220pf capacitor I had to replace.

  • Solder is def looking better.

  • Send me your address in a private message, I can try sending you a replacement ATMega328p.

  • A few other things to check:

    • Do you have MIDI out echoing the MIDI in?
    • Voltage on the >VCO point on the board?
    • Probe pin 6, 12, 13, 15, 17, 19 of the MCU and see if you observe anything else than 0V (better if you have a scope).

    Even with the MCU removed and faulty, the VCO should be oscillating and you should have signal at point G:

    Your problem is very strange because even if the MCU was kapout the LEDs would light up randomly; and the VCO would still oscillate (at a very low frequency). Have you checked the polarity of the LEDs?

  • 1. How do I check the MIDI out and IN?
    2. VCO (point A) is 0
    3. Pins on the MCU (ATMega right?) I get values on almost all pins.
    Point G I have a signal.

    The polarity of the LEDs is correct, infact, of I bridge two of the pins on IC16, LED 1 lights up

  • this is very vague.
    which values on which pins? (yes ATMega= MCU)
    which of the pins on C 16 make the led light up?

    1. Send some data on the MIDI in and check that it is forwarded to the MIDI out.
    2. Strange, because if this voltage is at 0V, it means the MCU has sent some data (the DAC is at half range during startup). Which voltages do you have on the other >VCF >VCA and >PWM pins.
    3. Which value?
    4. What kind of signal do you have point G? It should be a sawtooth wave. Continuing the signal chain you should then have some signal at point O for example (filter output), affected by both the cutoff and resonance settings.
  • Sorry for being vague, I was halfway out the door to work.
    1. I only have one MIDI cable so I’m not able to check if out echoes in right now.
    2.VCF is -.06, VCA, VCO and PWM are all 0
    3. I’m assuming the pins are numbered top row 1,3,5, etc and bottom is 2,4,6 etc.
    Therefore, pin 1 is 4.74
    pin 3,5,7,9.11 are all .24
    pin 13 is 0
    pin 15 is .01
    pin 17 is 5
    pin 19,21,23 are all .24
    pin 25 is .01
    pin 27 is .24

    Pin 2 and 4 are 5
    pin 6 is .24
    pin 8 is 5
    pin 10 is a changing value (keeps falling)
    pin 12 and 14 are 5
    pin 16 is 0
    pin 18 is .74
    pin 20 is .41
    pin 22 and 24 are 0
    pin 26 is .26
    pin 28 is a changing number (hovering around 1.8-2.2)

    4. I don’t have a scope, but the values are .04.3. I have a signal at O and yes the values are affected by the cutoff and resonance knobs,

  • Here is how chips pins are numbered.

    When I ask you to probe points VCO/VCF, I do not expect a voltage measurement, I want you to connect this to an amp and listen to the signal.

  • Sorry about the numbering…as for the amp, I don’t feel confident in being able to do that.

  • new numbering/values:
    pin 1 5 pin 28 4.74
    pin 2 5 pin 27 .24
    pin 3 .24 pin 26 .24
    pin 4 5 pin 25 .24
    pin 5 changing value pin 24 .24
    pin 6 5 pin 23 .24
    pin 7 5 pin 22 0
    pin 8 0 pin 21 .01
    pin 9 .74 pin 20 5
    pin 10 .41 pin 19 .24
    pin 11 0 pin 18 .24
    pin 12 0 pin 17 .24
    pin 13 .26 pin 16 .01
    pin 14 changing value pin 15 .24

  • it’s easy, just cut an audio cable, hold shielding against a ground spot and probe the points with the tip. or instead of cutting you can also use croco clamps.

  • The audio cable/amp procedure is mentioned in this thread It sems to be a common troubleshooting procedure. I think you’re really close to getting where you want to be.

  • From the MCU reading it looks like it is doing some work… What are the voltages at each pin of IC16?

  • IC16 is :
    pin 1 .01
    pin 2,3,4,5,6 are 0
    pin 7 5
    pin 8 0
    pin 9 0
    pin 10 5
    pin 11 0
    pin 12 5
    pin 13 0
    pin 14 5
    pin 15 0
    pin 16 5

    I’ll give the audio cable a try this afternoon.

  • ok, just tried the audio cable…I can hear something at all points except for ABCD
    The sound at QRST is not present at all points as well.

  • BTW, thanks for the alligator clip suggestion rosch, I was nervous about cutting up cables.

  • Does the sound you have at point O react to pots like cutoff/resonance? The sound at point H react to the PW pot?

    It seems to me that something is wrong near the MCU, which has two effects:

    • The unit doesn’t react to MIDI and does not generate control signals.
    • The unit doesn’t send status information to the LEDs.

    One thing worth trying: What if you set the VCF LFO mod pot to the highest value? Do you see any large voltage variation on point B?

  • point O reacts to cutoff and resonance, point H reacts to PW.

    VCF LFO mod did nothing to voltage at B

  • Now that you are familiar with the “probing audio signals” method, can you try probing:

    • Signal at pin 1 of the MCU (does it change when you move pots?)
    • Signals at pins 13 and 15 of the MCU? You should get there a buzzing sound with a 2.4kHz frequency.

    There’s definitely something wrong with the digital section. I suspect the analog section is all fine…

  • The signal (if there is one…I couldn’t really hear anything) doesn’t change when moving pots
    13 and 15 have a quiet buzzing ( I really had to boost volume to hear it)

  • Can you record the buzzing on pins 13 and 15?

  • sure. stand by.

  • I was wrong about pin 15, it was 16 that had a signal…15 had nothing

    pin 13.wav
    882K
  • Out of curiosity, have you tried with another power supply? I’m asking because the faint buzz in your audio recording has a main frequency close to 60 Hz, and every time I see noise/glitches aligned with the mains current frequency I always suspect power supply problems…

  • I have tried two different power supplies. I think the buzz is coming from my combination of patch cable/alligator clip/soundcard.

  • UPDATE:

    I just got the new IC in the mail today. Thanks pichenettes. I still have no power (lights or sound) but when I probe the points with an audio cable, there is a noticeable difference in the strength of the signal.

    I’m starting to think that there is an issue with the connectors between the boards. Does this make sense? Should I try replacing them?

  • If you can read +5V on the +5V point on the top board, it should be enough for the LCD and LEDs to light up.

  • which is the +5V point on the top board?

  • It’s labelled “+5V”.

  • I can’t find anything on the top board labelled +5v. Also, there is no LCD, this is Anushri

  • Hmmm sorry wrong message!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion