No square signal
  • Hi Everyone.

    First off let me say that assembling Anushri was a blast. The trippy smell of rosin takes me back to my childhood when I put together Heath Kits with my Dad. It is a great project and I’ll totally move on to building an Ambika once I get this first project working.

    It seems my Anushri only produces a synth signal when the sub level is set to the 12 o’clock position and when the mix knob is turned fully counter clockwise (all the way to the ramp). Doing a little reading on the forum I have confirmed that my pw, pw mod and vco mod knobs are set to a “sensible” 12 o’clock position. I have also been sure to disable sync for the square wave test. The signal gets louder when I throw the sync switch and much louder when I switch the sub to the bottom position. With sub level all the way up, and the sub switch all the way down, turning the mix knob to the square does alter the timbre (so I guess at least the knob works).

    Filters work, drums work, MIDI in works fine. The first level voltage tests (+/- 5V, 4.1V, etc.) all check out. I’ve checked my solder connections, even touched up a few. I’ve confirmed that my ICs are all in the correct sockets and with the correct orientation. I have a scope (but unfortunately no test leads). I have tried the audio test thing but haven’t had much luck finding an audio cable I can open to attach test leads to.

    Any suggestions would be appreciated.

    Regards,

    Scott

  • Have you soldered all jacks? I remember people having problems because they did not solder the PWM input jack (which does an implicit connection from the PWM pot to the comparator of the square waveshaper).

    If you think the sawtooth VCO is working correctly, then the problem is definitely the square comparator. Check that the voltage at IC9 pin 7 is 0V.

  • Thanks for getting back to me pichenettes.

    I checked the solder on the pw in jack (on all the jacks actually) and it looked fine. I touched up one other connection just to be safe.

    When I checked pin 7 on IC9 (I assume pin 1 is always the leftmost pin on the bottom row when looking at the main board with the mandala at the bottom right) and I see a fluctuating voltage between .6 and 1.0 volt. Maybe I have the wrong pin?

  • pin 1 is always left of the little notch at one end of the IC when you look from above (or, if there’s no notch there is a little dot in the corner at pin1), then numbers run around the IC counter clockwise

  • Thanks rosch. While I had pin 1 located correctly, I didn’t know that pins are counted counter clockwise. Good to know.

    So it turns out that the voltage showing on pin 7 of IC9 is -3.7ish volts. Not good I gather.

    Regards,

    Scott

  • What is the voltage on the middle pin of the PW pot? And the voltage on the PWM DAC output (the pad labelled PW on the board, near one of the MCP4822s)?

    The voltage on IC9 pin 7 should be roughly minus the sum of the two (okay, there are 10/12 and 10/15 factors thrown in…). If you don’t get that, I suspect that R29 is badly soldered, or that you have put the wrong resistor value in there. -3.7V means that the op-amp is clipping, probably from excessive gain.

  • The middle pin of the pw pot shows fluctuating voltage between -0.07 and 0.0V. The pwm pad shows fluctuating voltage between 1.4 and 2.5V. I rechecked the voltage on pin 7 of IC9 and it fluctuates between 2.9 and 3.4V. I gather this is high given the that it should be the sum you mentioned.

    I checked R29 and it is a 10K (brown, black, black, red). The joints look fine as well.

  • Wow, this is weird, all readings are totally wrong. If you remove IC9, what do you read on the middle pin of the PW pot, and on the PWM pad? Have you disabled everything that would cause PW modulation?

  • My apologies. The pwm mod knob was turned up. Can you tell me what else I can do to disable pw mod?

    With it turned down and with IC9 removed, the middle pin of the pw pot (not the pw mod pot) now measures -0.1V. The pw pad now measures 0V.

  • And inserting IC9 changes the voltages?

  • Pw pot now measures -0.09V, pw pad measures 0V and pin 7 of IC9 measures 0.66V.

  • If IC9 pin 7 is at 0V, you should hear the square at IC10 pin7 is that the case?

    What kind of signal do you have on IC10 pin 1?

  • Unfortunately I don’t have a way of checking the audio (at the moment). Pin 1 on IC10 shows a solid V.

  • Strange… What is the voltage on IC10 pin 1? It shouldn’t be very big – that’s the DC offset of the saw that gets into the waveshaper.

  • Sorry I meant to say that pin 1 on IC 10 shows a solid 3.11V

  • Check that R71 has one side at -5V and the other side at 0V. Check that R72 is correctly soldered.

  • I’ll need to remove the controller board for this test. Any issue with that?

  • Both R71 and R72 look properly soldered. I’ll give them a touch up just in case.

    R71 shows 0.29 at one end and 0.16 at the other (controller board removed)

  • Please do the tests with the two boards attached!

  • Interestingly the voltages are the same with, and without, the controller board attached: 0.15 at one end and 0.29 at the other.

  • And IC10 output?

  • IC10 pin 1 shows 3.11V.

    I just realized i was checking R75 not R71. R71 gives -4.04 at one end and -3.76 at the other.

  • So your -5V rail is not at -5V, right?

  • I’m sorry. I don’t understand what you mean by “rail”.

  • I’m sorry. I don’t understand what you mean by “rail”.

  • In the assembly instructions there’s a step at which you have to test the -5V voltage. Can you perform this test?

  • Is this the first round of tests in the instructions – the one with the red, green, blue, priple and cyan dots? If so, then I have done this. I got mostly +/- 4.92V. I can do it again though.

  • One side of R71 is tied to Vee, so it should be -5V. Something might have changed…

  • Also, I haven’t seen a photo of your board. Please post one!

  • Just did the basic voltage tests again and nothing has changed:

    Test point 1 on D2 shows 10.6V.
    Test point 2 on D2 reads 9.7V with relatively little fluctuation.
    IC14 reads 4.92V (as do all other positive (rail?) tests) (all blue reference points also checked)
    IC21 reads -4.96V (as do all other negative tests) (all blue reference points also checked)
    Both purple points check out at -4.04V
    The cyan point on IC13 shows +4.04V

    Here are the pics of my boards:

    http://www.flickr.com/photos/halflife/sets/72157632965716438/detail/

    Let me know what’s next. Thanks.

  • Have you done the test with all ICs inserted?

  • What are the voltages on each end of R71? One end of R71 is connected to the negative supply, so it shouldn’t read 4.04V nor 3.76V.

  • Just to confirm, R71 is the blue VCO trim pot, correct? I rechecked it and I get -4.04V on the end closest to the bottom of the board (closest to IC18). I get -3.76 at the opposite pin. BTW I’m using the ground point at the bottom of the board between IC22 and IC23.

    Thanks for your persistence and your patience.

  • No, R71 is not the trimpot. The trimpots are R74, R75 and R76.

  • Well I guess that makes a difference.

    So, with a red face, I measure R71 as -4.96V at the bottom most connection and 0V at the top point.

  • Ok.

    Then back to R70… Which voltages on both sides of it?
    And R72… Which voltages on both sides of it?

    Are you ready to make signal measurements?

  • R70 – 10k (brown, black, black, red) bottom pin measures 1.52V and top pin is 0.0V
    R72 – 27k (red, purple, black, red) bottom pin is 3.06V and top pin is 0.0V

    I also confirmed that R71 is a 39k (orange, white, black, red)

    Working on setting up audio testing (all of my bloody audio cables have molded ends). I may be able to try it tonight. If not, likely tomorrow.

  • Try reheating all solder joints on IC10, particularly pin3. Check that you have +/- 5V on IC10 pin 4 and 11.

  • All points on IC10 now retouched. I have +/- 4.96V on pins 4 and 11 respectively. Now I’m going to try out the unit to hear what’s going on.

  • No love. There is the possibility that I’m not understanding the synth’s architecture. Maybe I have the settings wrong and this is why I’m not hearing what I expect. Can you tell me the settings I should use to test the VCO?

  • Filter mode to LP, cutoff to its maximum value, resonance to 0 ; “mix” setting to middle position, PW and modulation settings set to middle position ; DCO / -1 / -2 selector to DCO and level pot set to 0.

  • Thanks. What should I set “Sub level” to? Attached is what I hear when it is turned up all the way.

    When it is turned down, I hear nothing.

    anushri_test.wav
    922K
  • Sub level set to 0. Then you should hear the VCO – hear its shape change when moving the “shape” pot; and hear it be PWM modulated when PW is changed.

  • I turned down the Sub level and this attached is what I hear. (hint: very quiet)

    BTW I have the cables now to do some audio point testing.

    anushri_test2.wav
    970K
  • Then head over to the build instruction and listen to poin “F” – you should hear there the VCO sawtooth output.

  • I do hear a signal (sawtooth I trust) – attached. Very quiet and poor SNR. Is this what I should be expecting to hear?

    anushri_vco_point_F_test.wav
    987K
  • There’s a problem here – the signal should be very loud and clear (it should be 2.5V pp). It seems to there’s a problem with the VCO then – but it’s curious that it is still producing a sawtooth wave. Maybe there’s something wrong with your measurement procedure.

  • I might have done the test incorrectly. Here’s what I did:

    I tested a 1/4” TS cable connecting Anushri to my sound card (level set to unity). Drum machine sounds loud.

    I then connected the sleeve of the TS plug to the ground point on IC21 (via a test lead).

    Next I connected the tip of the TS plug to pin 7 of IC7 (point “F” on the test diagram) via a test lead.

    I recorded the test output using my DAW.

    Any suggestions? Maybe use a different ground point?

  • ....and for laughs, I tried this test again using another ground point. Results are the same. Lots ‘o hiss, small saw wave.

  • Any chance this is caused by a bad IC7?

  • I don’t think so. Have you check that you haven’t swapped by mistake a transistor with one of the voltage references or another transistor?

  • I’ll confirm the transistors. brb

  • I checked the orientation of the transistors at IC1, Q1, Q2, IC12 and IC13 and they all look good. The part numbers on the transistors IC1, Q2, IC12 and IC13 all read “22ME70E MFC41I T1”. None of them say LM4040 on them. Is this cause for concern?

  • No, this is the right part.

  • Thanks. If I installed the transistors so the flat side matches the flat side of the labeling on the board, are they definitely installed correctly? (assuming my solder points are good)

  • You could post a photo of your board for confirmation, but this looks OK.

  • Let me know if these are good enough:

    http://www.flickr.com/photos/halflife/sets/72157632965716438/detail/

  • Between which pair of holes is the capacitor C9 soldered?

  • The outer 2 holes (middle hole is left empty).

  • Ok that’s good. I fear you won’t be able to know more without using proper test equipment.

  • I gather it’s time to fire up the oscilloscope? Do I execute the test procedure at the bottom of the assembly instructions, or is there another procedure?

  • I’d like to have a reliable measurement (oscilloscope trace) of the signal at points E, F, G.

  • Ok. I’ll have to order a new probe. Once I’ve got it, I’ll get back to you with the measurements.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion