No sound, no lights, power distribution checks out [SOLVED]
  • What could this be? I checked all solder joints, reseated the ATMEGA. Using a 9V PSU. Upon turning it on I just hear a ‘plock’ sound.

    Voltage readings (according to the Power Distribution chapter in Troubleshooting):

    1: 8.4V
    2: 7.6V
    3: -7.3V
    Red points: all 4.9V
    Green points: all -4.9V
    Purple points: all 4V
    Cyan point: -4.1V

    Triplechecked the LED polarities :)

  • Could you post photos of your board?

  • Sure! Sorry for the bad quality. Dark around here. Will post better quality pictures tomorrow morning.

    http://jstsch.com/misc/2014/7/anu_1.jpg
    http://jstsch.com/misc/2014/7/anu_2.jpg

  • PS: during construction the only doubts I had was about the orientation of the resistor network. Am I correct that the lettering should be placed inwards?

    lettering.jpg
    1962 x 1050 - 312K
  • Resistor network looks good.

  • OK, thanks, good to know!

    Fresh pics are here :)

    http://jstsch.com/misc/2014/7/bottom_1.jpg
    http://jstsch.com/misc/2014/7/bottom_2.jpg
    http://jstsch.com/misc/2014/7/control_board.jpg
    http://jstsch.com/misc/2014/7/top_1.jpg
    http://jstsch.com/misc/2014/7/top_slanted_1.jpg
    http://jstsch.com/misc/2014/7/top_slanted_2.jpg

  • I have a spare 328 lying around… would it be useful to try swapping it around or is this a useless maneuver? I would expect the leds to work with just the AVR, correct?

  • Yes, that could be a good test. Do you have anything to program it?

  • It already has a bootloader, Optiboot (since it came out of a broken JeeLabs LedNode). So I’ll just pop it into an Arduino and…. oh wait! I see that you have your own bootloader, correct?

    http://mutable-instruments.net/static/firmware/anu_bootloader.hex

    Then load the firmware itself using MIDI?

    http://mutable-instruments.net/static/firmware/anu_0.92.syx

    OK… I think I remember you can use an Arduino as an ISP programmer… I’ll read up and go that route then :)

  • For this test you don’t really care which bootloader is there…

    So use the chip with optiboot. Flash it with this .hex file:
    http://mutable-instruments.net/static/firmware/anu_0.92.hex

    Put it on your board. If it works, I’ll send you a replacement 328p with the correct stuff installed on it.

  • Well, that is interesting! Flashing went OK (328 in Duemilanove, avrdude to upload the .hex). Now: sound! But no LEDs. Controllers seem to work, but not the buttons. I get an oscillator, can use the knobs on the synth section. Sub oscillator/filter/LFO all seems fine (and cool too) :) But I can’t switch to the kbd/ctrl or drums part.

  • Fried multiplexer? A short somewhere? Hmm.

  • Hmm! Looking at the schematics. I think I’ve switched the 74HC165AN and M74HC59581 around. D’oh!!! Let’s reseat them.

  • Perfect, it works! And it’s a lot of fun :) I’ll take a look at the original 328 again. But no need to send me a new one, this one was doing nothing anyway :)

  • The original 328 has no issues whatsoever. I guess it’s a fluke that it didn’t make audio with the ICs switched around yet the other time it did make audio.

    Thanks a lot, will post a pic with beautiful case in the consensus thread soon :) now to put on the knobs ;)

  • So glad you solved it! I looked at your pictures for ICs with the wrong orientation, but didn’t check for swapped parts…

    With the swapped 74hc595/74hc165 + the official MIDI bootloader, the synth stays stuck in firmware upgrade mode. Having the wrong IC in place of the 74hc165 simulates a key press during boot which locks the synth in firmware upgrade mode. That’s why it didn’t boot at all with the original chip; but still booted with the optiboot bootloader.

  • Hah! Mystery solved :)

    I put colored LEDs in mine (blue at the top, white/red/green below), but they’re a bit too bright ;) will increase the resistance a bit.

    Cheers, it’s a lovely piece of kit!

    anu.jpg
    816 x 612 - 53K