Anushri hasn't worked from the beginning
  • I built my Anushri a year ago and it didn’t work properly so I put it away and now that I have time I want to try and get it working.

    When I power it up LEDs 1,3,5 light up, with midi connected I press a note on my keyboard and the LEDs go out and stay out until I power off and on the unit. I get no audio at any point, with any toggling, turning, or button pushing.
    Any thoughts?

  • No. My first guess would be a faulty MCU but lets have a High Res look at both boards, both sides if we can spot anything obvious

  • Do you have a multimeter and can you do the measurements in the trouble shooting section here ?
    Is your MCU (atmega) from the kit or self sourced?

  • I do have a multimeter, and did the testing last year and to the best of my ability everything looked ok, but I have no training per se but I can always try it again. The MCU came from the kit. I’m sure the photos I’m attaching are horrible so please let me know if there’s something I can focus on better.

    anushri.jpg
    1017 x 763 - 73K
    anushri 2.jpg
    1017 x 763 - 99K
    anushri 3.jpg
    1017 x 763 - 98K
    anushri 4.jpg
    572 x 763 - 74K
  • Could it be stuck in firmware update mode ?

    From the manual:
    “Keep the Hold key pressed while Anushri is powered on to put it into firmware update mode. Every second LED will be lit. “

    So that could be LED 1+3+5, as you describe. It is waiting for a SysEx file on the midi input. But as you are not sending that (you send note data), it could just give up (LEDs out).

    Perhaps try to reset the unit ?
    From the manual:
    “Keep the Run/stop key pressed while Anushri is powered on to revert all synthesis and system settings (including tuning compensation!) to their default values.”

    Worth a try.

    If that’s not the way to get out of firmware update mode (it is indeed in that mode !), you might have to actually send a SysEx file, as described in the manual.

  • This reminds me… I need to get my Anushri properly working too. I can’t believe I’ve let it sit on the shelf so long. Shame on me.

  • Indeed ! Quite a fun piece of kit !

  • I’ve rechecked the measurements and everything looks good. Resetting didn’t do anything new.I guessI’ll try and send the sysEx message next.

  • The results of the sysEx load are a mixed bag. It loads, I get a tone that I can then change with some tweaks but some of the knobs do nothing, to get the vco to stop I have to mash a bunch of keys at the same time, and none of the other modes work(drums, rec, etc.). When I power the unit off again nothing, the same problem that I started with is their, no sound the same LEDs waiting for a sysEx command. Am I looking at a bad MCU?

  • OK, good to hear that sending the SysEx got things going again for a bit – at least that seems to indicate that the Anushri gets stuck in ‘firmware upgrade mode’ when powering up. MCU itself seems fine, as it updates the firmware.

    Now, it gets into the ‘firmware upgrade mode’ by pressing the ‘hold’ key when powering up. I’m guessing you are not doing that, but it could be that there is a short in the key (near its legs, or one of the traces, or elsewhere) so that it is always seems to be pressed as far as the MCU is concerned :)

    What happens next is consistent with that: pressing the ‘hold’ key long enough produces a drone tone (see the manual) – and that seems to be what happens in your case ! So the ‘hold’ key never seems to be released to the MCU, and you get the drone tone after the firmware update happened. Next time you power up you get in ‘firmware upgrade mode’ again …

    So check the soldering around the hold key, and its route to the MCU.
    Note that the button is labeled ‘Util’ on the schematics, and its signal is labeled IN1.
    The signal travels from the button to the MCU through one of the connectors (pin 11 on J5).

    Looking at the schematics, the IN1 signal first goes to IC22 (a 74HC165), which you also need to check (its pin 11), and also check the orientation of resistor network RN1 (dot at pin 1).
    The 74HC165 could be dead, perhaps, if all of the buttons behave strangely, or have a bad power connection.

    Hope this helps !

  • Just looked at your pictures again – soldering of the 74HC165 socket (IC22 at the bottom left) does not look pretty – try to reflow the solder (taking out the IC first).

  • What you couldn’t see from the pics is that I actually had IC15 and 22 switched because I’m so blind. Voila, the problem is solved. When I get a chance I am going to test some of the other functions, but I don’t think the VCO detune and range knobs are making any changes.

  • Good to hear !

    Just hope these chips are both OK – IC15 (one of the 4050’s) could have different pin outs.
    The 4050 is a buffer for the gate and clock I/O’s, so easy to see whether these still work or not.

    If all is fine now, do enjoy the Anushri !

  • Do either of those ICs affect any of these functions? VCO detune and range, PW, FM, and VCO mod because none of these currently function.

  • No, I don’t think IC15 and IC22 have anything to do with those …

    But you might have swapped some more ICs :-)

  • I checked the others thinking the same thing but they are all fine. Thanks a lot for getting me to this point!

  • If I may use this thread to help diagnose my anushri, I’d appreciate it. So, I probed my anus(hri) for all of the power points as described in the trouble shooting section. Everything checked out great until I got to the (-) voltage section. I only got -.73 volts at the 7905 and all other points after that. The cyan point also didn’t show anything close to normal at all. So, would this point to a faulty 7905? If so, what could have caused that? Could an excessive amount of heat from soldering damage the 7905? Anyway, thanks for letting me hijack, but maybe I don’t have to make a big fix in order to get a working Anushri!

    Cheers!

  • Do you get -0.73 volts on the input pin of the 7905, or the output ?

    The LT1054 plays a big part here, so do check voltages there as well. If the LT1054 is not connected well, or broken, the 7905 can’t fix that …

  • Ack – good point. I just pulled up the schematic to check the flow of electrons. I’m at work right now, so I’m going off of memory, but I think I observed the faulty voltage as early as Point 3 (output of the inverter). This would make sense, since the 7805 heatsink was getting hot, but the 7905 heatsink was cold. That would mean, it’s not getting full voltage, correct? Now, what’s a more likely scenario? 1) I toasted the LT1054 when I reflowed the solder points or 2) I still have a faulty solder point on the socket? I think I can acquire a new LT1054, so I’ll start with that. Thanks for your help! Eelco for President!

  • President ? Wouldn’t want to take Olivier’s job :-)

    If the 7905 heatsink stays utterly cold (should actually get less hot than the 7805 one), there is likely a problem with the LT1054. First check soldering etc. before replacing: these are not the cheapest ICs around …
    Also check the orientation – you would not be the first to … well, you know.

  • Eureka!! Well, here is what I had to do. I inspected the solder points on the main board and found many that were suspicious – especially around the LT1054 and in the (-) voltage path. This was my first major soldering project, I had a crappy soldering iron and I was a crappy solderer. After re-flowing and re-doing as many joints as I could, I plugged it in and did the voltage check again. I am seeing all the proper voltages at all the test points! It’s getting late, so I’ll plug this bad boy in tomorrow. I hope it’s all back in order – feeling pretty good so far!

  • Sounds good. And the LT1054 seems to be fine – great !

    Anushri was my first MI synth as well, but I had some soldering experience already, so had no issues except for forgetting to solder some (well, six, actually …) of the pins of a TL072 …

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion