YAM - alternative Ambika firmware
  • Hello!

    I,ve now ported my alternative firmware YAM (Yet Another Mutation) originally developed for Shruthi to Ambika.

    The latest source code and README is available on GitHub . Here’s the status of the firmware when I post this:

    • PolyBlep implementations replace the original band-limited ‘saw’ and ‘square’ oscillators for higher fidelity and less memory footprint (Polyblep implementation inspired by, but less general than, Oliviers prototype for STM). For ‘square’ this primarily mean that the oscillator now have a more proper sounding PWM, i.e. more edginess, and no loudness drop for PWM modulation parameter above 0. For ‘saw’ there is no gentle high pass pre-filtering and the modulation is different. The parameter for saw now add mix of a 2nd saw edge, resulting in a saw with sub oscillator (actually super oscillator) sound.
    • Triangle oscillator (‘triangle’) is no longer band-limited (to reduce memory footprint) and is folded (instead of clipped) upon modulation.
    • Added a quad PWM oscillator (‘qpwm’) very similar to the quad saw (‘pad’). The modulation parameter simultaneously affects both detuning of the four pwm oscillators and the pulse width.
    • Added an alternative FM oscillator (‘fmfb’) with feedback modulation. Just as for the regular FM oscillator, the modulation parameter defines the FM amount, but for modulation values above 64 increasing amount of feedback is added. At moderate levels the feedback adds ‘grit’. At higher settings it adds digital distortion (deliberately left in).

    NOTES ON PATCH (PROGRAM) COMPATIBILITY with official Ambika firmware:
    Due to qualitative differences of the ‘saw’ and ‘square’ oscillators etc, levels may have to be adjusted somewhat to mimic original patches. If you really miss the original saw oscillator from the official firmware, this one is still available as ‘oldsaw’ (it’s high-pass sampled and have a different character).

    I’ve attached built binaries that can be used to update the firmware using the instructions in the manual BUT DO SO AT YOUR OWN RISK!

    EDIT: deleted attached firmware file. See an updated README on GitHub, and later firmware builds later in this thread.


  • Be careful when renaming the firmware files and putting them on the SD card for firmware upgrade.

    The controller file should be named AMBIKA.BIN, and you need to put six copies of the voice card file named VOICE1.BIN, VOICE2.BIN,..., VOICE6.BIN. It’s all in the manual .

    If you mix up the controller and voice card files you may end up in this situation.

  • Great! Are the additional oscillators ‘indexed’ at the end or will they interfere with current patches? Thanks.
    Edit: It looks like you moved the new oscillators to the end. Awesome.

  • Seems amazing Bjarne, good job! Will gove this a spin as soon as possible. Thank you!

  • @funkyfli Yes I moved the new oscillators to the end for the sake of improved patch compatibility (even though it made the code somewhat ugly).

    Glad you like it!

  • Out of the blue question but how is everyone getting along with this update?

  • It works fine for me but of course I’m biased :)

  • It’s time for a bug report and an update!

    I’m not sure if you’ve noticed but I’ve found a bug – there’s harsh digital distortion when using dual ‘qpwm’ oscillators. The problem is most likely due to CPU overload and I don’t have a solution for this bug at the moment.

    I’ve added a new polyblep saw oscillator similar to the CS-80 inspired ‘csaw’ found in Braids. Attached is a build for the daring of you, and as per usual, the source and README is found here . Always read this and be careful if and when updating the Ambika firmware!

    Edit: deleted attached firmware file

    Have a nice weekend

  • Another issue found :(

    The harsh digital distortion due to CPU overload does not only occur with dual oscillators quad oscillators, but also the fm oscillators. Since these oscillators work fine on Shruthi, I conclude that there is significantly less CPU cycles for oscillators available on Ambika. I need to get back to the drawing board and figure out what to do about the quad and fm oscillators in YAM for Ambika.

    Sorry for the inconvenience.


  • Just a note that this is highly appreciated, speaking for two (2!) excited Ambika owners over here!

  • Bonjour,

    I (believe I) have fixed the digital distortion issues due to CPU overload for the FM and Quad oscillators. Attached is a build of the firmware available on GitHub .

    I’ve found out that it’s not always very intuitive to understand what’s the bottleneck based on the C++ alone. I’ve had to look at the disassembled code to find the issues. For the Quad oscillators it turned out that it was 16 bit phase comparisons that was too much, so I had to replace them with somewhat ugly 8 bit comparisons instead (yielding the exact same output though).

    For the FM oscillators I had to replace an interpolated table lookup with a straightforward table lookup for the modulating sine wave. Even though this theoretically implies some additional bit of quantization noise, I’ve done some A/B listening tests, and cannot hear any differences whatsoever.


    Edit: deleted firmware file

  • @accountboy Glad you like it!

  • I am really excited to try this out.

  • Wow!

    The saw and square have much more ‘punch’ now, and the new csaw is fat and warm. Fmfb sounds like the fm should: with the distortion.

    Recent update removed the subtle distortion the qpwm had before. It sounded quite interesting with the distortion appearing randomly when tweaking the modulation parameter. Didn’t notice any unwanted distortion on fmfb though. After the update it sounds cleaner with more pronounced grit and distortion starting points when increasing the modulation. Actually I can’t decide which firmware to keep: the one with unwanted distortion or the one without. I wish I could keep them both.

    Thank You Bjarne! You’re a Hero!

  • With the firmware, would I need to adjust the individual voice cards or just change out data on the SD card? New to this, a bit lost :/

  • @gummi you need to put the AMBIKA.BIN, VOICE1,...,VOICE6.BIN on SD card and follow the Firmware Update section in the manual .

    But beware, as evident in this thread you can mess up if you’re uploading the wrong firmware file to the voice cards.


  • I think I am capable of handling that:)

    If I love the new Polyblep oscillators enough such that I found the original saw/squ/tri redundant, is there any way to remove them from the firmware and put the new ones in the front of the oscillator options?

  • @gummi As stated in the README on GitHub the new saw,square and triangle replace the original oscillators as the first oscillator options. The old saw is at the end of the selection, together with the qpwm, fmfb, and csaw. Since it’s open source you can of course change whatever you want, but you’ll have to know what you’re doing. It’s not hard to change order of oscillator options but you may mess up patch compatibility (more).

  • Whoops ! I thought you meant that all the new saw/squ/tri are at the bottom. I’m at work and juggling projects, reading comprehension is poor right now:(

    Excited to load them after work, in a clearer state of mind !

  • @gummi No worries. I’ve chosen a compromise between backwards compatibility and changes that works well for me (and I hope, many others). I’m sure others could have chosen either a “100% compatibility” or a “let’s start from scratch” approach. Cheers

  • Thanks a lot for making this firmware for the ambika. I just tried it and it is great. I just realized I had an alternate firmware somebody made where the whole parameter was capitalized instead of just the first letter (like FREQ instead of Freq) and the keytrack and vel parameters were set on the filter page instead of having to go in the matrix. Any chance you would consider something like that for this firmware?

    I know you said you didn’t want to break patch compatibility, but any chance you would consider modifying the behavior of the envelope (adr) in the matrix. Even if it was just fixed to env1, that would be nicer than having it change all 3 rates at once.

    But again, thanks very much for this.

  • @cs1729 I actually got a similar request from TheSlowGrowth regarding the envelope modulation, also he asked if I had a “buy me beer” button somewhere :) I cannot really make any promises of if and when I’ll incorporate what you request. I’m not to fond of the capitalization, but the envelope modulations would be useful. I really made this firmware for myself to explore new oscillator models, but with the MI community it seemed natural to make it public to the community.

  • Cool. Thanks. I understand. I don’t want to be a feature requestor. But I had to try with the envelope thing. It is one thing that bugs me about the ambika.

  • @cs1729 I may have a go at it when I have some time for hacking, but don’t hold your breath. Cheers

  • @Bjarne thank you so much, super fantastic! just brilliant !

  • Hey Bjarne thanks so much for this!

    I am also interested in seeing the mods suggested by cs1729 added.

  • Thanks a lot for your work ! :)

  • I really dug that capitalisation firmware too.

  • I found the modified firmware here (https://github.com/phase57/ambika)

    I’m trying to figure out if there is some easy way to fork one of them and merge the changes from the other, but I don’t really know what I’m doing so there is a lot to read. But it looks like the changes are all pretty different except to the readme and the osinfo file.

  • @cs1729 Yes, I’m aware of the phase57 mod and kind of guessed this was the one you’ve been using. I may do a merge (would be straightforward) when I have time to work on the firmware. Cheers

  • Hi again!

    On popular demand I’ve ported some of the phase57 modifications to YAM. Filter modulations for velocity and keyboard follow are now added to the filter page, and are received via midi CC (108 and 109 respectively). The edited parameter is now displayed in all uppercase characters.

    Attached is an updated YAM firmware build. As always, checkout the YAM README at GitHub and think twice before updating your firmware. Be careful out there!


    P.S. It will take some time before I do any further extensions, such as envelope modulations etc. D.S.

  • Awesome! Thanks for adding this stuff.

  • I have experience with coding, but not code in this style before.

    If I wanted to re-organize each oscillator in the menu …

    I am guessing each oscillator type has a variable assigned, so in the osc type parameter it is organized with this variable i.e. 0=silence, 1=saw, 2=square, etc.

    Would I just need to edit the table and assign oscillators in the order I want to the variables within that parameter table, or …?

    Just a sentence or two should get me on the right track:) Mainly wanting to ensure if I do what I said above, that there aren’t other areas of the firmware to edit that I’m unaware about.

    I just want to add things together in a way that makes sense to the existing paradigm of oscillator options – FM feedback next to other FM oscillator, quad pwm next to pad, etc.

  • Order of oscillators are defined implicitly in fn_table_ in oscillators.cc, and this must match order of enum in patch.h and strings in strings.py.

    You also need a fully compatible tool chain to build. Search this forum for hints and of course see this and this

    Edit: the above refers to Shruthi code base but it applies to Ambika as well, except that for Ambika, source is divided in controller, voicecard, and common parts.

    I have of course considered doing what you request BUT that would break patch compatibility and I think a lot of people would be malcontent.

    Good luck

  • I have just started to build an Tubika kit and are looking forward to try this firmware out.

  • hey Bjarne

    thanks a lot for merging!!!
    Now, I will also use your firmware:-)

  • Hey Bjarne and all, did some comparison tests for the old firmware and your new one… I can’t upload them here because the files are too big, but you can find them at Gearslutz: https://www.gearslutz.com/board/11751764-post129.html

    I am sold on the new oscillators! (And the quick access of env->vcf / kbd -> vcf is great as well!) Thank you very very much for this work!

  • @bjoern Thanks for the comparisons and shedding some light on the YAM modifications (I’m not on gearslutz). Also, I realize I have spent more time on coding than doing demoes. Cheers

  • Hi. Potential bug report. so I installed this on an Ambika with 6 polyvox filters, and after installation, the resonance control was reversed. it affected all the presets. Resetting to factory hasn’t fixed the issue.

  • Hmmm, I don’t think this qualifies as a bug report (even if your problem is real), because as far as I know neither the official firmware nor the YAM firmware has any explicit support for the polivoks filter. I believe you must have had some custom firmware installed in the 1st place. I could browse github forks of the Ambika repository to find a guess of which. It may be possible to add the polivoks support, but maybe something else has to go then, because the controller firmware only has a few precious bytes left.


  • This is probably the custom firmware you were running

  • thanks for the info. do you know if .bin files for that firmware is available? I dont have the tools to make any.

  • I simply searched the forum and found this thread . I guess you could PM scannerboy

  • @MuppetsAttack PM me your e-mail and I’ll send you a build of the polivoks voicecard firmware (no YAM) so you can get back to where you started. Cheers

  • thanks for your help!

  • thanks, but BarclayPedals hooked me up. :)

  • @MuppetsAttack, Does the filter reversal still function in the proper value ranges (i.e. 0 is now 127, 1 is now 126, etc)? Did the YAM firmware just cause a flip of the control ‘polarity’, so to speak? I was wanting to add a Polivoks filter as a mono voice to my Ambika, I don’t have many patches saved (and it wouldn’t be the death of me to just re-edit the patches) but I want to make sure I could use the YAM firmware for the voices. The new saw/square sound so much nicer for bass I would hate to lose them altogether

  • It had the full range, it was just reversed. the thread BJarne referenced has a fix for it, but it was beyond me. to quote:

    You can flip the resonance in a simpler way by just changing this line:

  • I had a strange problem compiling a couple of nights ago. The version of the tools directory (d73c7b8) does not seem to exist in that repository. Updating to the latest version of tools (1c8c71c42a2290975153972de9b66a51f21fd7b0) seemed to work okay and I was able to successfully load the binaries and run them.

    Additionally to compile on my mac I had to change line 24 of controller/resources.cc by replacing the backslash ‘\’ with a forward slash ‘/’.

    I believe this change needs to be made on line 24 of voicecard/resources.cc as well.

    I only had time to try out the sawtooth, but what an amazing change! The saw has a lot of power and body that the original saw is lacking. Looking forward to trying the PWM.

  • Hi!

    Not sure about the tools directory, but the resource files are generated automatically via “make resources” based on the python files, and I’ve also noticed that the file separators in the generated resource files are platform dependent (and I haven’t bothered to polish the make file system). You either have to regenerate them yourself, or do what you did and hack the generated files directly.


  • Okay. Has been troubleshooting my last voice for 2 hours now. It sounded thin and needed attack, and I have been thru every single component and solderjoint.. Now I realise that the last voicecard still runs the original firmware. YAM sounds like a trillion. Thank you Bjarne.

  • @MikkelM Thanks! :)

  • I have now been using this amazing machine for a while and for a noise-lover like me, it would be splendid to have an highpass- filter after the osc, noise and sub has been mixed together.

    I was wondering how easy it is, to change the code for the bitcrusher to an highpass filter?



  • @MikkelM I like the idea and a super primitive high pass would be straightforward in terms of coding BUT I’d say it’s impossible without butchering some major sound generation (subosc etc) based on the remaining available clock cycles.

    The next thing I’ll attempt is improving the oscillator shape selection order in the UI with kept patch backwards compatibility (as in latest YAM for Shruthi). Also, I’d like to improve some of the wave tables as suggested by Olivier.


  • @Bjarne. Damn I thought it was straight forward to replace the calculation for the bitcrusher.
    Sounds nice with the other improvements you are working on.

  • First. Thanks @bjarne for all the work!

    I wonder if adding some new modulation destinations is challenging. I don’t quite understand why we can’t modulate other modulation amounts. Seems trivial. Was it to keep the ui clean or is there a computational limitation?

    Would also be nice to modulate specific envelopes and lfos. Oh and things like spread and lfo and osc shapes too. I just wanna modulate everything…. :)

    Anyhow I know that’s not what you sound interesting in working on but just curious if the design choice is about avoiding clutter or something else.

    Thanks again. YAM is great :)

  • > I don’t quite understand why we can’t modulate other modulation amounts

    You can use the modifiers to combine modulation sources.

    > Was it to keep the ui clean


    > Oh and things like spread and lfo and osc shapes too. I just wanna modulate everything…. :)

    LFO don’t have variable shape.

    OSC shape is already variable.

    Spread is not a patch parameter. It doesn’t impact the oscillators but detunes directly the MIDI note sent to the voicecards.

  • Ah. I see. You’re right. I hadn’t read up on modifiers.

    I got carried away fantasizing.

    One thing that would be useful for me is if there was a way to get the ui to switch the page for any parameter that has just been changed via midi.

    A while back I was experimenting with setting up an external knobby controller to have more direct access but when I have to page over on the ambika itself it kind of defeats the point.

    Maybe there’s a way to do this I also haven’t discovered. Anyhow thanks!

  • > One thing that would be useful for me is if there was a way to get the ui to switch the page for any parameter that has just been changed via midi.

    You don’t really want that if you start sequencing the synth with automations, and try to control another parameter live. Or if you’re using automation on two parameters that are on different pages…

  • @MikkelM The problem is that a bitcrusher is such a trivial effect that takes barely any resources. If you were going to swap it for anything else, it would need to be similarly cheap (in terms of cycles). Even the simplest filter is too expensive I fear.

  • @MuppetsAttack I did a special build of the latest YAM firmware for the Ambika Polivoks filterboard (with inverted resonance). If you want to try it out you can find it here . Cheers

  • @Bjarne, thanks so much! I’ll check it out tonight : )

  • Hi. This firmware sounds amazing and I really want to try it out but so far have had no luck. I can’t understand why as reading this thread (and a similar one on Gearslutz) makes it sound so simple! Here’s what’s happening:

    So I’ve downloaded the latest firmware from Github, renamed to AMBIKA.BIN and VOICE1.BIN... VOICE6.BIN on the SD card. Pop it in and follow the instructions BUT...

    For the controller firmware, after pressing S1 for ‘Upgrade’ it exits the Library page and displays the Filter page

    For the Voicecard firmware, after pressing S4 for ‘Upgrade’ it briefly says ‘Install’ and seems to take its time doing something.

    However, there are no new oscillators and it still sounds aliased in the high registers. This might sound like a stupid question but how do I know if it worked?

    Hope someone can help me as I’m desperate to try this update!


  • Hi @mattski,

    I just realized I hadn’t uploaded the latest firmware binary for the controller on Github, so please try again with the one I just uploaded (rename ambika_controller_YAM160303.bin to AMBIKA.BIN).

    After pressing S1 for upgrading the controller, the screen will read “SD update…” for a while, then “Done”, and after that the unit is rebooted, and you’ll end up on the filter page. That’s normal.

    If the update succeeded the system about page will read “ambikaYAM v.1.0”, and at the end of the oscillator shape selection you will find “oldsaw”, “qpwm”, “fmfb” and “csaw”. As described in this thread and Github there are also changes of the “saw”, “square” and “triangle” shapes.


    P.S. Note that YAM does not improve on aliasing in high registers in general, e.g. the original “saw” and “square” waveforms were already pre-filtered for anti-aliasing and didn’t alias more than YAM do. When I started YAM I primarily wanted to achieve an anti-aliased PWM oscillator with the same bite as the original dirty pwm. The polyblep’d “square” in YAM has the same bite as the wildly aliasing original “pwm”, but with aliasing similar to the original “square”. I’m rambling. D.S.

  • Hey Bjarne,

    Thanks for replying so quickly and uploading the firmware. Unfortunately I’m getting the same issue. I’ve tried different versions of YAM firmware and new SD cards but always get the same problem. The firmware just doesn’t want to update. I might try an emergency firmware update but am a bit worried that I’m going to render my Ambika unusable!

  • Sorry to hear that. Have you tried the same procedure with the official firmware? I doubt this issue is YAM specific.

  • Where does your Ambika come from? Maybe it doesn’t have a bootloader?

  • @Bjarne – yes, almost certainly! I’ll try it with some alternate firmware.

    @pichenettes many thanks for the reply. I had the Ambika built for me by a well known builder. Is there an easy way to tell if the bootloader is installed?

  • > Is there an easy way to tell if the bootloader is installed?

    Non-working firmware updates are a symptom that the chips have been programmed without the bootloader.

  • @pichenettes

    OK, thanks for the info, much appreciated. I’ll go and speak to the builder, see if it can be rectified.

  • nice one, I totally forgot about this and when I come back to check it out, you have added more to it.

    Thanks so much for putting the time in and sharing with the community.

  • Glad you like it :)

  • Hi there,

    I’m a newbie here so please pardon me if my question is maybe not relevant.

    I have just had a trusted builder build an Ambika for me with 6 Tubeohm ladder filter voices (Christmas is coming ;-).

    In the distortion mode (one of the 3 modes for the filter) I have noticed that when I turn the resonance all the way up and if i then do a filter sweep the stepping of the 64 steps are very audible. However when the envelope generators does a filter sweep I did not noticed this stepping. Also i have a Shruti with the standard SM4 card and had never noticed such stepping (maybe had not paid that much attention in my Shruti but here it is so prominent i noticed it right away). I guess it’s probably because the resonance gets super loud in this distortion mode.

    Do you know if there is any workaround this problem. I was thinking that if the envelope has enough precision to sweep without a perceptible stepping that might be achievable with the cutoff pot with some sort of smoothing effect. Do you know if the CV output generated by the Cutoff pot could be sort of smoothed (or maybe that’s already the case and then it’s a matter of changing the time over which the smoothing happens)?

    Thanks in advance for your help and again please excuse me if i have a question that might stupid.

  • Hi GoldfishSynth,

    I’ve also noticed that the response of the ladder filter is quite sensitive at high resonance, and this is probably why you hear the steps of the filter cutoff parameter for this filter, and not for SMR4.

    Modulation with envelopes are implicitly smoothed when they’re updated every 40th sample. It may be computationally feasible to introduce some kind of smoothed parameter changes (as is done in the more CPU hungry braids implementation) but I am uncertain, and I don’t see any quick fix for this.


  • thanks Bjarne for the quick answer!

  • hi,

    i’d love to try this firmware, but I have the same problem as mattski above. Loading the controller firmware appears to work : the upgrade option is available and on selecting it loads then reboots. However the firmware name is still “ambika v1.0” so it appears it was unsuccessful.

    i then tried loading the voicecard firmware, but this left the voicecards in the “Port X device ?” state, so i reinstalled the original voicecard firmware, which returned them to working state.

    Are these symptoms in line with not having a bootloader installed. If so, what is the easiest way to get it installed so i can install the update.


  • Hi @Parappa,

    as Olivier suggest the symptoms are in line with not having a bootloader installed. As far as I know the only way of installing a bootloader is by flashing the firmware, which involves using an ISP programmer and having a development environment setup, see this .


  • Hi,

    Thanks for your help ! Would this do the job ? (ATmega644p listed as compatible) ?



  • It seems ok but the only one I’ve personally used is this one from DIAMEX on Windows 10. I know others on this forum have used different ones successfully.

  • The cause was indeed the missing bootloader and with it installed I could easily install the firmware

    Thank you for your help @Bjarne and of course for your creating this excellent firmware

  • Also worth noting to others with the same issue – I used ebay seller hheniek48 for a replacement chip with the bootloader installed. Very friendly and professional seller – he usually has a few ambika related items for sale. And it’s cost effective if, as I was, you’re planning to buy a programmer just for this one task

  • @Bjarne

    Finally got the bootloader issue sorted. Just wanted to say thank-you so much for the excellent update, I’m absolutely loving my Ambika right now!

  • Hi , sorry for the hassel with the Bootloader . I had never though that it comes a Firmware update for Ambika/TuBika after Olivier had stop it . So i had flash the Atmels without Bootloader . Also because i flash it direct with the AVR MK2. From 04.11.2016 – to now and in Future all Atmels for Ambika/Tubikai had the bootloader inside.
    Shruthi from 16.02.2016 >>> If there are any problems – please contact me .

  • Good to hear it finally worked out and that the “mystery” is solved.

  • Any kind souls with audio examples using the new waveforms that they would like to share?


  • Well, I’ve spent far too little time on making demos for YAM. There some snippets of audio over at the YAM for Shruthi thread . I recommend just trying it out (if you’ve got an Ambika with an installed boot loader that is) – you can always revert the firmware.


  • Pretty convincing! I’ll definitely have a go with YAM.

    Thanks for the firmware updates.
  • Hey! Is this compatible with the Tubeohm Ambikas? SVF version. And do their Ambikas come with the necessary boot loader?

  • Yes, YAM is just as compatible with all Ambikas as the official firmware. The exception is the Polivoks card that requires a patch (for both YAM and the official firmware).

    Normally a boot loader is flashed, but only the person who originally flashed the chips can know for sure.


  • Doh, just tried this and realised my Tubika doesn’t have the bootloader. hmph.

  • I was wondering if anyone that had the boot loader missing resolved their issue?

    I used an ISP to program my Ambika and voice cards and I’m 100% sure I loaded the boot loader, but seem to be having the similar issues as the people without the boot loader.

    I flashed the stock firmware using: avrdude -B 1 -V -p m644p -c usbtiny -P usb -U flash:w:ambika_controller.hex:i -U flash:w:ambika_controller_boot.hex:i -U lock:w:0x2f:m
    and it went fine.

    So the issue I had was as follows:
    For example, I took the file named ambika_controller_YAM160303.bin and renamed it AMBIKA.BIN
    I went to the “about page” hit S1 and the screen started showed the Ambika updating, but then it froze at roughly 60k and when I rebooted it had nothing but empty characters on the screen. (shaded in boxes)

    If I went to refresh using an ISP to reload the stock firmware it runs fine.

    If I went to update the voice cards to YAM I had the same issue as with the motherboard/controller.

    Are there hex files available for YAM?

  • @matrix12x Just to make sure I downloaded the latest YAM build (bin file) and updated my Ambika controller and it worked without issues, i.e it progressed all the way up to 61440 bytes and then signaled Done, and then rebooted.

    If you’d like I can provide you with all the hex files for YAM but (A) I don’t understand how this could make a difference, and (B) I’ve never flashed my Ambika using ISP so I’m kind of useless in terms of further troubleshooting.


  • @matrix12x Just a thought: could the YAM downloads from GitHub have failed or been non-binary?

  • oh, quite possibly.
    How would I check?
    Also, yeah, could I please get the hex files from you.

  • @matrix12x Attached are both built hex and bin files corresponding to YAM160303 for Ambika

  • @Bjarne the hex files worked perfectly. Maybe my browser is messing up the files when I download them from GitHub or something.

  • @matrix12x That’s probably it. Glad to hear you got it sorted

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion