Anushri - Electrical Surge
  • Hello all,

    Unfortunately I had an electrical surge on Sunday evening that fried my Anushri power supply (a regulated PSU from Maplin…nothing major).
    I was scared I ahev fried Anushri as well but it works with another PSU.

    The only issue I have now is that the Octave knob and the Range Knob have lost their functionality, in the sens that when I turn them to the extremes the variations in tune is just one semitone.

    I have tried to look through different troubleshooting posts but I have not found any similar issue.

    would you be so kind to explain me what I have to check?
    or if you already know the answer, please let me know if I have to change any component.

    Thanks

  • So everything but those two knobs works perfectly fine?

  • yes.
    it seems like that.

  • Then check the soldering on them – if it was your atmega that was fried, you should have a dead machine on your hands.

  • maybe the 4051s that scan the pots?

  • Cool thanks guys.
    I will check tonight and will report asap.

    :)

  • Hello, just to let you know.
    I have checked the soldering and it is alright.
    So I have been without a solution but:

    I pressed hold and record twice and everything came back to normal…the synth tracks voltages well and I just needed to adjust teh calibration again…weird…

    Anyway problem sorted it seems

    Thanks

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion