Trouble updating Yarns firmware - seems to work, then doesn't
  • Strange one here. I put the yarns into “snake” loader mode and then send the sysex. The yarns display sits on 00 the entire time – it never increments – but when the sysex finishes the yarns flashes “ok” and resets. Only it doesn’t have the new firmware features so it didn’t seem to update. I’m using an iconnectMIDI (original one) and I’ve used it in the past to update the yarns firmware successfully.

  • The “OK” shows up when the module receives the final packet that instructs the module to reboot.

    So it looks like the module is receiving only the last packet but not the previous one. Can you increase the delay between messages?

  • Maybe the individual sysex packages are too big (some midi interfaces simply don’t transmit sysex packages larger than a certain size)? Even if it worked before – maybe the sysex file that worked had packages just long enough and the new file has packages that are too large? Just a guess… I’d try another interface

  • Thanks for the response – that is helpful. I am going to point the finger at something in mutable’s sysex for now because based on my sysex librarian history I’ve updated 50 devices, old and new, across many manufacturers, via this same interface without a single hiccup before. I’ll see if I can borrow another MIDI interface or even use my iPad one.