OLED 20x2 with full hd44780 compatibility?
  • I bought a slightly beaten up Korg DSS1 and after getting it fully functional I swapped the LCD with dead backlight out for a 20x2 OLED (Winstar).

    Now after switching on the synth it appeared to be a complete success, but I’ve noticed a few problems which lead me to believe that either the synth firmware is doing something odd or the display isn’t fully compatible.

    When changing modes (SYSTEM, MULTI etc) the first line of the LCD is supposed to say something like * * * SYSTEM MODE * * *. But it appears blank. If I press the button twice again (once to go to another page and then back) you get a few spaces and * * * SYSTEM M.

    So the question is, does this seem like some sort of timing issue or character set related?

    At the moment it is usable, but I’m not satisfied obviously.

  • I am really interested in this. Hopefully someone here has an idea. My DSS is awaiting the straylight upgrade as well. Sorry i am no help.

  • The actual upgrade is quite simple and you can remove the connector to the board with the contrast pot (to power down the backlight inverter which whines).

    Then it’s a case of moving over all the wires one by one. The OLED has two extra pins at the top of the holes for the 16 pin connector which you ignore.

    Just a shame it doesn’t work 100% at present. The display might need some extra initialisation perhaps.

    It looks nice, but if anything crucial is shown at the top of the screen it might not be shown.

    Some screens work fine:

  • If nothing is shown the problem is that theres no standard for the alignment of the screen buffer in memory for 2x20 displays…. so depending on how they write into the LCDs memory it might or might not work.
    If some garbage is shown the Display has the wrong Character Set.

    Theres also no defined standard for 2x16 and 2x40 Memory addresses but every one i have seen have the same, whereas i have 2 2x20 that handle the 2nd row different

  • Aha, so the easiest solution is to try another display?

    Not sure I can be bothered to try to modify the firmware or even if it is possible for me.

  • Trying a Midas display next, hopefully it will be “golden” :)

  • Report back how it went. I could do some dirty trading involving a Newhaven OLED if needed later.

  • Sadly the new display looks to be an identical display to the old one, just with a different brand on it. Not even worth the hassle of fitting it.

    The number ends with 2002A on the back of the PCB, so if you see that you’ll know its the same. Newhaven also brand it.

    My have to resort to an LCD, this requires removing the backlight inverter and sticking a resistor in there. Plus sorting out the contrast voltage range. Much like the Wavestation AD mod here

  • I just installed one of the new Vishay OLEDs at Mouser and have the same result. From the research I’ve been able to dig up it seems to be a Timing issue with what is seemingly the Winstar WS0010 controller (Info found on CrystalFontz OLED). They are all the same OLEDs and the New Haven OLED forums have shed some light on the HD44780 compatibility.

    Some links…

    http://www.newhavendisplay.com/NHD_forum/index.php?topic=897.0

    http://www.newhavendisplay.com/NHD_forum/index.php/topic,1005.msg2338.html#msg2338

    I Imagine the DSS upgrade guys could fix this in the firmware somehow but they don’t seem very active.

    OLED.jpg
    640 x 480 - 144K

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion